WordPress.org

Indonesia

Ready to get started?Download WordPress

Forum Bahasa Indonesia

ngga bisa edit post (14 posts)

  1. daniiswara
    Anggota
    Posted 6 years ago #

    sejak wp 2.5, 2.6.1 saya ngga bs edit (hanya) suatu posting/konten yg isinya (post+komen) agak panjang..dg pesan error:

    Fatal error: Maximum execution time of 30 seconds exceeded in /home/…/public_html/wp-includes/wp-diff.php on line …

    line ... -nya random lokasinya tp berdekatan..

    masalah serupa:

  2. Huda
    Administrator
    Posted 6 years ago #

    Masalahnya sebenernya gak serupa sih :D.

    Klo punya dr. Dani itu, phpnya "nyerah" karena dieksekusi terlalu lama. Itu di server hostingan ya? Pernah nyoba mematikan fitur post revision? Biasanya agak ringan setelah itu.

    wp-diff.php itu pustaka untuk merender diff antara satu revisi dengan revisi lainnya dalam sebuah tulisan. Baru ada di wordpress 2.6. Jadi harusnya di 2.5 gak ada :D. Apa maksudnya "sejak wp 2.6, 2.6.1"?`

  3. daniiswara
    Anggota
    Posted 6 years ago #

    oh beda ya hud..:D
    yap hostingan..
    saya coba nambah baris
    define ('WP_POST_REVISIONS', 0);
    ngedit post-nya nanti belakangan nyusul..
    wp 2.5 apa 2.6 ya..kayaknya bener mulai wp 2.6 :)
    makasi ya hud..kl tetep ngga bs, nanti minta resep lainnya lg..

  4. Huda
    Administrator
    Posted 6 years ago #

    Itu cuma terapi simptomatik aja sih. Dan itu juga menghilangkan salah satu fitur WP (post revision). Terapi definitifnya, ganti hostingan yg servernya punya horsepower yang lebih :D. Atau minimal, kita tunggu aja updatean berikutnya. Moga2 ada enhancement2 dlm sisi efisiensi eksekusi perintah2 php & kueri MySQL. Di milis memang banyak keluhan kayak gitu. WP semakin hari semakin berat.

    Mengenai post revision, pendapat saya pribadi, memang gak semua dari kita butuh. Lebih cocok untuk multi-author blog di mana satu artikel ditulis secara kolaboratif. Tapi ya kembali ke kita masing2 sih. Butuh apa nggak :)

  5. daniiswara
    Anggota
    Posted 6 years ago #

    @hudatoriq:
    confirm..masalahnya masih sama hud..resep lainnya dong.. :)
    (selain pindah hosting lho..)

  6. Huda
    Administrator
    Posted 6 years ago #

    Hmmm.. apalagi ya? Coba ilangin bbrp plugiN?

  7. pengki
    Anggota
    Posted 6 years ago #

    atau coba hapus row-nya post revision di database ?

  8. daniiswara
    Anggota
    Posted 6 years ago #

    @huda: ya, itu yg pertama tak cb tp tetep gagal..
    @pengki: saya blm nyoba liat di db, nanti deh dicoba..tq all

  9. daniiswara
    Anggota
    Posted 6 years ago #

    ternyata..setelah mencoba bbrp cara dan konsul admin hosting sekiranya ada mslh di server, tetep gagal utk mengedit post yg panjang tsb.. :(

    tp post2/tulisan2 lainnya masi bs diedit spt biasa..

  10. Huda
    Administrator
    Posted 6 years ago #

    Boleh tahu spec servernya?

    Btw, pernah nyoba ngedump MySQL nya ke server lokal? Trus juga semua berkas2 nya juga disalin ke kompie lokal, Trus diedit di kompie? Apa juga time out kyk gitu?

    Coba juga plugin2 nya diuninstal, apa pengaruh?

  11. daniiswara
    Anggota
    Posted 6 years ago #

    info server: aries (biar adminnya baca trackback jg..)
    blm nyoba lokal, free space lg penuh je (php+mysql malah tak hapus)..blm sempat bersih2 lg..

    deactivate ama uninstal plugin beda ya..br nyoba deactivate semua plugin, kondisi plugin updated, tp stlh dicoba bbrp kali hasilnya sama aja..

    posting bermasalah itu saya buat salinannya persis (masi draft), tanpa komen2nya..bs diedit spt biasa..

  12. daniiswara
    Anggota
    Posted 6 years ago #

    akhirnya..stlh nyoba saran mas pengki (menghapus baris post_type revision2 tulisan tsb) dan http://wordpress.org/support/topic/192853?replies=9#post-852154 (walau kasusnya agak beda karena post_name saya masi berurut), ternyata..tetep ngga bs dgn pesan kesalahan sejenis..tp ngedit di post di db-nya masi bs..

    trus hapus jg baris autosave-nya..coba edit..dan bisaaa...
    makasi semuanya :)
    judul thread ini bs ditambahi [solved]

  13. Huda
    Administrator
    Posted 6 years ago #

    Oke :).

    Sekedar info tambahan buat yg tetap ingin menggunakan fitur post revision tapi terbentur kendala maximum execution time server yg terbatas, bisa juga mengubah nilai max execution time (menimpa nilai standar php.ini) dengan cara menambahkan baris ini di .htaccess

    php_value max_execution_time 200

    Contoh di atas mengubah maximum execution time ke 200 seconds. Tapi harap cara ini dipergunakan secara bijak karena dalam kondisi tertentu, mematikan proses yg berjalan cukup lama itu juga hal yg fisiologis :).

  14. daniiswara
    Anggota
    Posted 6 years ago #

    sekadar laporan aja..ternyata setelah WP_POST_REVISIONS diaktivin lg..masalah emang kumat..abis ngedit, save (halaman memang terupdate) lalu muncul pesan error ituh..

    kmrn dl berkas post_revision di db ada 6
    skrg cuman ada berkas autosave (revision0?? tp ktnya autosave ngga bikin post_revision..cmiiw) dah error jg..

    akhirnya dari info di http://lesterchan.net/wordpress/2008/07/17/how-to-turn-off-post-revision-in-wordpress-26/ dan http://www.optiniche.com/blog/422/autosave-post-revision-control/, saya disable aja sekalian post_revision-nya..

    spt harapan yg lain di http://wordpress.org/support/topic/175886?replies=49, mungkin lbh enak kl ada panelnya di admin drpd masuk langsung ke db-nya/phpmyadmin

    memang dah ada bbrp plugin utk itu..

Topik Ditutup

Topik ini telah ditutup untuk balasan-balasan baru.

About this Topic